Wednesday, August 27, 2014

Debian (wheezy) Eclipse error: GLib-GObject-WARNING libgdk-x11-2.0.so

Do you have a problem to run Eclipse or STS (Spring Tool Suite) on Debian Wheezy? Is your error message when you start Eclipse, like this:


user@comp:~$ eclipse/eclipse
GLib-GObject-WARNING **: crashing aplications
...
Problematic frame: C [libgdk-x11-2.0.so.0+0x5173f]
...


The problem is that glibc library is older than Eclipse needs. The default version of the library is glibc-2.13-1 and Eclipse need version glibc-2.14 or higher, but these versions glibc libraries are missing in Debian stable repository.
My solution is to add the official unstable/testing repository to APT, and then install the newer version glibc library.

Add the official unstable/testing repository in the "/etc/apt/sources.list":

deb http://http.us.debian.org/debian/ testing non-free contrib main
deb http://http.us.debian.org/debian/ unstable non-free contrib main
deb http://http.us.debian.org/debian/ wheezy non-free contrib main

Search for a newer version glibc Library in the repository:


user@comp:~$ sudo aptitude search glibc
...
v   glibc-2.13-1
v   glibc-2.19-1  
...


Install a newer version glibc library:


user@comp:~$ sudo aptitude install glibc-2.19-1


You can now successfully run Eclipse.

No comments:

Post a Comment